Печать страницы - Плохо работают субтитры

Light Alloy forum

Light Alloy на Русском => Баги => Тема начата: alexander-mex от 30 Ноябрь 2017, 19:04:15



Название: Плохо работают субтитры
Отправлено: alexander-mex от 30 Ноябрь 2017, 19:04:15
Всем привет! Давно заметил, что у меня плохо работают субтитры (встроенные). Я специально скачиваю фильмы, где есть форсированные субтитры на надписи или иностранную речь, но так получается, что сами субтитры могут появится всего 1 раз за весь фильм (где-то в начале фильма). Потом они не появляются. Это было замечено не с одним фильмом.


Название: Плохо работают субтитры
Отправлено: vmsoft77 от 30 Ноябрь 2017, 19:59:14
To alexander-mex:
Фильмы в каком контейнере (avi, mkv,...)?


Название: Плохо работают субтитры
Отправлено: Oscar от 01 Декабрь 2017, 04:49:52
но так получается, что сами субтитры могут появится всего 1 раз за весь фильм (где-то в начале фильма). Потом они не появляются. Это было замечено не с одним фильмом.
В таких случаях необходимо прилагать ссылки на тестовые сэмплы, или хотя бы на полноценные видео файлы с форсированными субтитрами, в которых проблема проявляется стабильно.

Ну и также, какой используется обработчик субтитров - встроенный, или внешний?


Название: Плохо работают субтитры
Отправлено: samplistic от 26 Март 2019, 12:45:14
какие "необходимо прилагать ссылки на тестовые сэмплы/видео/фильмы"?? :(
ваш плеер регулярно пропускает субтитры в КАЖДОМ едрить фильме контейнера .mkv,
это наблюдал на протяжении долгих лет, сейчас вот решил проверить - скачал десятки прошлых версий плеера, и скажу, что эта беда с субтитрами началась после версии Light Alloy 4.8.8 (v4.8.8 - все в порядке! :) а с 4.8.8.1 вплоть по 4.10.2 - субтитры рандомно пропускаются) ::)


Название: Плохо работают субтитры
Отправлено: MegaVolt от 27 Март 2019, 19:32:06
Тоже уже задолбали пропуски субтитров :(
В плеере есть возможность подключить внешний нормальный обработчик субтитров? Как это сделать и какой обработчик поставить?
Ато уже иногда подумываю о смене проигрывателя :)

To samplistic: спасибо за исследование, возможно откачусь на ту версию, если в ней других багов не найдётся :)


Название: Плохо работают субтитры
Отправлено: vmsoft77 от 27 Март 2019, 20:28:25
В плеере есть возможность подключить внешний нормальный обработчик субтитров? Как это сделать и какой обработчик поставить?
Возможность отключить встроеный обработчик сабов имеется (см. криншот).
Хотя, я не понимаю, что нужно делать с настройками плеера\системы, чтобы проявлялась вышеописанная ситуация с сабами. ???


Название: Плохо работают субтитры
Отправлено: MegaVolt от 27 Март 2019, 22:23:12
Ничего особо с настройками не делается. Меняю максимум с десяток настроек от дефолтных, с которыми ставится плеер. Меняю поведение при запуске программы и при загрузке файла, и значения прыжков при перемотке вперёд\назад кнопками клавиатуры, ну и шкурку ещё. Не в какие дебри больше не лазию.
Галку эту я убирал, тогда титры пропадают и всё. В системе установлен DirectVobSub, но он не подхватывается почему-то. Может нужно ещё что-то тут тыкнуть?


Название: Плохо работают субтитры
Отправлено: Al321 от 28 Март 2019, 17:04:48
To MegaVolt:

Попробуйте VSFilter.dll от разработчиков MPC-BE.
Его вручную зарегистрировать в системе , встроееный в LA отключить как показал выше vmsoft77

Будут ли с ним пропуски ?

Сплиттер DTS\AC3 - я не понимаю зачем отключать...


Название: Плохо работают субтитры
Отправлено: MegaVolt от 28 Март 2019, 19:14:47
AC3 тоже установлен внешний, на некоторых фильмах проблемы с громкостью наблюдаются, приходиться микшировать каналы вручную. (А ведь раньше мне кажется в самом ЛА была такая возможность.)

Тэкс, с VSFilter разобрался, я оказывается х64 версию ставил, забыл что у нас только х86.
Поставил х86 от MPC-BE, эта версия норм подгружается, НО она так же пропускает субтитры! Те же самые, что и встроенный в ЛА обработчик.  code_prob

Есть ещё какой-то xy-VSFilter, попробую ещё с ним поиграться. Ну или откат на 4.8.8  :-

Добавление от 29 Март 2019, 00:05:32


С xy-VSFilter всё точно также. Подозреваю что проблема не с VobSub, а со сплиттером матрёшки...

Добавление от 29 Март 2019, 00:26:39


Да, догадка подтвердилась. Установил Haali Media Splitter, в ЛА отключил встроенный сплиттер матрёки, и всё пошло.
Ну чтож, будем посмотреть на других фильмах дальше. :)


Название: Плохо работают субтитры
Отправлено: Al321 от 30 Март 2019, 01:22:12
To MegaVolt:
 Спасибо за тесты.

 Сплиттер встроен в VTRenderer - так что до "разморозки" проекта Vortex ом врядли баг будет поправлен.

 В качестве внешнего сплиттера для матрешек в Ла подойдет и LAV . Или MatroskaSplitter из MPC-BE (если не хочется захламлять систему лишними фильтрами)